import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a [a-zA-Z=\"#\\s'.,?а-яА-Я0-9:><;%$&\\/]+\\/a>)";
final String string = "<br>\n"
+ "<a href=\"https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского\">Кошки Достоевского</a>\n"
+ "<a href=\"https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского\">Кошки Достоевского</a>\n"
+ "Роман Фёдора Михайловича Достоевского, впервые опубликованный в номерах журнала «Русский вестник» за 1868 год. Являлся одним из самых любимых произведений писателя, наиболее полно выразившим и нравственно-философскую позицию Достоевского.\n"
+ "<a href=\"#\" onClick='this.innerHTML===\"1 \" ? this.innerHTML=\"2 \" : this.innerHTML=\"1 \"'>1 </a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}