const regex = /(<a [a-zA-Z="#\s'.,?а-яА-Я0-9:><;%$&\/]+\/a>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a [a-zA-Z="#\\s\'.,?а-яА-Я0-9:><;%$&\\\/]+\\\/a>)', 'gm')
const str = `<br>
<a href="https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского">Кошки Достоевского</a>
<a href="https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского">Кошки Достоевского</a>
Роман Фёдора Михайловича Достоевского, впервые опубликованный в номерах журнала «Русский вестник» за 1868 год. Являлся одним из самых любимых произведений писателя, наиболее полно выразившим и нравственно-философскую позицию Достоевского.
<a href="#" onClick='this.innerHTML==="1 " ? this.innerHTML="2 " : this.innerHTML="1 "'>1 </a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}