$re = '/(<a [a-zA-Z="#\s\'.,?а-яА-Я0-9:><;%$&\/]+\/a>)/m';
$str = '<br>
<a href="https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского">Кошки Достоевского</a>
<a href="https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского">Кошки Достоевского</a>
Роман Фёдора Михайловича Достоевского, впервые опубликованный в номерах журнала «Русский вестник» за 1868 год. Являлся одним из самых любимых произведений писателя, наиболее полно выразившим и нравственно-философскую позицию Достоевского.
<a href="#" onClick=\'this.innerHTML==="1 " ? this.innerHTML="2 " : this.innerHTML="1 "\'>1 </a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);