import Foundation
let pattern = ##"(<a [a-zA-Z="#\s'.,?а-яА-Я0-9:><;%$&\/]+\/a>)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<br>
<a href="https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского">Кошки Достоевского</a>
<a href="https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского">Кошки Достоевского</a>
Роман Фёдора Михайловича Достоевского, впервые опубликованный в номерах журнала «Русский вестник» за 1868 год. Являлся одним из самых любимых произведений писателя, наиболее полно выразившим и нравственно-философскую позицию Достоевского.
<a href="#" onClick='this.innerHTML==="1 " ? this.innerHTML="2 " : this.innerHTML="1 "'>1 </a>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)