# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@section\(\'(.*?)\'\)(.*?)@endsection//sg;t' <<< "@section('title')
Number 1
@endsection
@section('content')
Number 2
@endsection"