import Foundation
let pattern = #"@section\(\'(.*?)\'\)(.*?)@endsection"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
@section('title')
Number 1
@endsection
@section('content')
Number 2
@endsection
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)