// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)@section\(\'(.*?)\'\)(.*?)@endsection").unwrap();
let string = "@section('title')
Number 1
@endsection
@section('content')
Number 2
@endsection";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}