use strict;
my $str = '@section(\'title\')
Number 1
@endsection
@section(\'content\')
Number 2
@endsection';
my $regex = qr/@section\(\'(.*?)\'\)(.*?)@endsection/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";