$re = '/@section\(\'(.*?)\'\)(.*?)@endsection/s';
$str = '@section(\'title\')
Number 1
@endsection
@section(\'content\')
Number 2
@endsection';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;