package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)@section\(\'(.*?)\'\)(.*?)@endsection`)
var str = `@section('title')
Number 1
@endsection
@section('content')
Number 2
@endsection`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}