using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@section\(\'(.*?)\'\)(.*?)@endsection";
string substitution = @"";
string input = @"@section('title')
Number 1
@endsection
@section('content')
Number 2
@endsection";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}