import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^html_4[]\\t !\"#$%&\\'()*+,.\\/0-9:;<=>?@A-Z[\\\\\\\\_`a-z\\{|\\}~^-]+[\\n\\r]";
final String string = "bingkai.php\n"
+ "html_3.php\n"
+ "html_4_dinawid wdiawuond.php\n"
+ "html_5.php\n"
+ "html_6.php\n"
+ "html_4_dinawid wdiawuond.php\n"
+ "html_7.php\n"
+ "html_8.php\n"
+ "html_9_dmoawdm wdawd.php\n"
+ "kode.php\n"
+ "wdwad.php\n"
+ "xxx.php";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}