// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"(?m)^html_4[]\t !"#$%&\'()*+,.\/0-9:;<=>?@A-Z[\\\\_`a-z{|}~^-]+[\n\r]"##).unwrap();
let string = "bingkai.php
html_3.php
html_4_dinawid wdiawuond.php
html_5.php
html_6.php
html_4_dinawid wdiawuond.php
html_7.php
html_8.php
html_9_dmoawdm wdawd.php
kode.php
wdwad.php
xxx.php";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}