const regex = /^html_4[]\t !"#$%&\'()*+,.\/0-9:;<=>?@A-Z[\\\\_`a-z{|}~^-]+[\n\r]/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^html_4[]\\t !"#$%&\\\'()*+,.\\\/0-9:;<=>?@A-Z[\\\\\\\\_`a-z{|}~^-]+[\\n\\r]', 'm')
const str = `bingkai.php
html_3.php
html_4_dinawid wdiawuond.php
html_5.php
html_6.php
html_4_dinawid wdiawuond.php
html_7.php
html_8.php
html_9_dmoawdm wdawd.php
kode.php
wdwad.php
xxx.php`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}