# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^html_4[]\t !\"#$%&\'()*+,.\/0-9:;<=>?@A-Z[\\\\_`a-z{|}~^-]+[\n\r]"
test_str = ("bingkai.php\n"
"html_3.php\n"
"html_4_dinawid wdiawuond.php\n"
"html_5.php\n"
"html_6.php\n"
"html_4_dinawid wdiawuond.php\n"
"html_7.php\n"
"html_8.php\n"
"html_9_dmoawdm wdawd.php\n"
"kode.php\n"
"wdwad.php\n"
"xxx.php")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.