import Foundation
let pattern = ##"^html_4[]\t !"#$%&\'()*+,.\/0-9:;<=>?@A-Z[\\\\_`a-z{|}~^-]+[\n\r]"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
bingkai.php
html_3.php
html_4_dinawid wdiawuond.php
html_5.php
html_6.php
html_4_dinawid wdiawuond.php
html_7.php
html_8.php
html_9_dmoawdm wdawd.php
kode.php
wdwad.php
xxx.php
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}