#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*?)(?=Hello|:)|^(?!.*(Hello|:)).*$"
Local $sString = "Let's go see Hello Dolly: A Classic Movie" & @CRLF & _
"Let's go see: A Classic Movie, Hello Dolly" & @CRLF & _
"Howdy" & @CRLF & _
"Well Hi, Hello My Friend" & @CRLF & _
"My Favorite Pizza Place: NYC" & @CRLF & _
"Hello" & @CRLF & _
": a movie"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")