use strict;
my $str = 'Let\'s go see Hello Dolly: A Classic Movie
Let\'s go see: A Classic Movie, Hello Dolly
Howdy
Well Hi, Hello My Friend
My Favorite Pizza Place: NYC
Hello
: a movie';
my $regex = qr/^(?:.*?)(?=Hello|:)|^(?!.*(Hello|:)).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}