$re = '/^(?:.*?)(?=Hello|:)|^(?!.*(Hello|:)).*$/m';
$str = 'Let\'s go see Hello Dolly: A Classic Movie
Let\'s go see: A Classic Movie, Hello Dolly
Howdy
Well Hi, Hello My Friend
My Favorite Pizza Place: NYC
Hello
: a movie';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);