using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.*?)(?=Hello|:)|^(?!.*(Hello|:)).*$";
string input = @"Let's go see Hello Dolly: A Classic Movie
Let's go see: A Classic Movie, Hello Dolly
Howdy
Well Hi, Hello My Friend
My Favorite Pizza Place: NYC
Hello
: a movie";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}