import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*?)(?=Hello|:)|^(?!.*(Hello|:)).*$";
final String string = "Let's go see Hello Dolly: A Classic Movie\n"
+ "Let's go see: A Classic Movie, Hello Dolly\n"
+ "Howdy\n"
+ "Well Hi, Hello My Friend\n"
+ "My Favorite Pizza Place: NYC\n"
+ "Hello\n"
+ ": a movie";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}