# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^'\s*//gm;t' <<< "<dox>
' <member type=\"Public Sub\" name=\"Increment\" return=\"void\">
' <param type=\"Integer\" name=\"nBase\" out=\"true\" />
' <param type=\"Integer\" name=\"nStep\" out=\"false\" />
' <purpose>
' purpose here...
' </purpose>
' </member>
' <member ... />
'</dox>"