// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^'\s*").unwrap();
let string = "<dox>
' <member type=\"Public Sub\" name=\"Increment\" return=\"void\">
' <param type=\"Integer\" name=\"nBase\" out=\"true\" />
' <param type=\"Integer\" name=\"nStep\" out=\"false\" />
' <purpose>
' purpose here...
' </purpose>
' </member>
' <member ... />
'</dox>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}