#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^'\s*"
Local $sString = "<dox>" & @CRLF & _
"' <member type="Public Sub" name="Increment" return="void">" & @CRLF & _
"' <param type="Integer" name="nBase" out="true" />" & @CRLF & _
"' <param type="Integer" name="nStep" out="false" />" & @CRLF & _
"' <purpose>" & @CRLF & _
"' purpose here..." & @CRLF & _
"' </purpose>" & @CRLF & _
"' </member>" & @CRLF & _
"' <member ... />" & @CRLF & _
"'</dox>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)