# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^'\s*"
test_str = ("<dox>\n"
"' <member type=\"Public Sub\" name=\"Increment\" return=\"void\">\n"
"' <param type=\"Integer\" name=\"nBase\" out=\"true\" />\n"
"' <param type=\"Integer\" name=\"nStep\" out=\"false\" />\n"
"' <purpose>\n"
"' purpose here...\n"
"' </purpose>\n"
"' </member>\n"
"' <member ... />\n"
"'</dox>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.