import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^'\\s*";
final String string = "<dox>\n"
+ "' <member type=\"Public Sub\" name=\"Increment\" return=\"void\">\n"
+ "' <param type=\"Integer\" name=\"nBase\" out=\"true\" />\n"
+ "' <param type=\"Integer\" name=\"nStep\" out=\"false\" />\n"
+ "' <purpose>\n"
+ "' purpose here...\n"
+ "' </purpose>\n"
+ "' </member>\n"
+ "' <member ... />\n"
+ "'</dox>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}