using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^'\s*";
string substitution = @"";
string input = @"<dox>
' <member type=""Public Sub"" name=""Increment"" return=""void"">
' <param type=""Integer"" name=""nBase"" out=""true"" />
' <param type=""Integer"" name=""nStep"" out=""false"" />
' <purpose>
' purpose here...
' </purpose>
' </member>
' <member ... />
'</dox>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}