#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![0-9-]+$)(?:[a-z]{2,}-?|[0-9]-?)+(?<!-)$"
Local $sString = "" & @CRLF & _
"(NULL STRING ABOVE)" & @CRLF & _
"555" & @CRLF & _
" 5" & @CRLF & _
" 5-yes" & @CRLF & _
" this-slug" & @CRLF & _
"--bad-slug" & @CRLF & _
"-bad-slug" & @CRLF & _
"bad--slug" & @CRLF & _
"bad-slug-" & @CRLF & _
"bad-slug--" & @CRLF & _
"b" & @CRLF & _
"a" & @CRLF & _
"d" & @CRLF & _
"b-a-d" & @CRLF & _
"go-od-2-ba-d" & @CRLF & _
"1-b" & @CRLF & _
"good-b4d" & @CRLF & _
"1-1b" & @CRLF & _
"1-1" & @CRLF & _
"1-2-33" & @CRLF & _
"go-od-to-go" & @CRLF & _
"1-good-slug" & @CRLF & _
"10-good-slugs" & @CRLF & _
"best-slug-ever" & @CRLF & _
"good-slug" & @CRLF & _
"slug-123" & @CRLF & _
"good" & @CRLF & _
"good-1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")