using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![0-9-]+$)(?:[a-z]{2,}-?|[0-9]-?)+(?<!-)$";
string input = @"
(NULL STRING ABOVE)
555
5
5-yes
this-slug
--bad-slug
-bad-slug
bad--slug
bad-slug-
bad-slug--
b
a
d
b-a-d
go-od-2-ba-d
1-b
good-b4d
1-1b
1-1
1-2-33
go-od-to-go
1-good-slug
10-good-slugs
best-slug-ever
good-slug
slug-123
good
good-1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}