const regex = /^(?![0-9-]+$)(?:[a-z]{2,}-?|[0-9]-?)+(?<!-)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![0-9-]+$)(?:[a-z]{2,}-?|[0-9]-?)+(?<!-)$', 'gm')
const str = `
(NULL STRING ABOVE)
555
5
5-yes
this-slug
--bad-slug
-bad-slug
bad--slug
bad-slug-
bad-slug--
b
a
d
b-a-d
go-od-2-ba-d
1-b
good-b4d
1-1b
1-1
1-2-33
go-od-to-go
1-good-slug
10-good-slugs
best-slug-ever
good-slug
slug-123
good
good-1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}