$re = '/^(?![0-9-]+$)(?:[a-z]{2,}-?|[0-9]-?)+(?<!-)$/m';
$str = '
(NULL STRING ABOVE)
555
5
5-yes
this-slug
--bad-slug
-bad-slug
bad--slug
bad-slug-
bad-slug--
b
a
d
b-a-d
go-od-2-ba-d
1-b
good-b4d
1-1b
1-1
1-2-33
go-od-to-go
1-good-slug
10-good-slugs
best-slug-ever
good-slug
slug-123
good
good-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);