# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?![0-9-]+$)(?:[a-z]{2,}-?|[0-9]-?)+(?<!-)$"
test_str = ("\n"
"(NULL STRING ABOVE)\n"
"555\n"
" 5\n"
" 5-yes\n"
" this-slug\n"
"--bad-slug\n"
"-bad-slug\n"
"bad--slug\n"
"bad-slug-\n"
"bad-slug--\n"
"b\n"
"a\n"
"d\n"
"b-a-d\n"
"go-od-2-ba-d\n"
"1-b\n"
"good-b4d\n"
"1-1b\n"
"1-1\n"
"1-2-33\n"
"go-od-to-go\n"
"1-good-slug\n"
"10-good-slugs\n"
"best-slug-ever\n"
"good-slug\n"
"slug-123\n"
"good\n"
"good-1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.