use strict;
my $str = '
(NULL STRING ABOVE)
555
5
5-yes
this-slug
--bad-slug
-bad-slug
bad--slug
bad-slug-
bad-slug--
b
a
d
b-a-d
go-od-2-ba-d
1-b
good-b4d
1-1b
1-1
1-2-33
go-od-to-go
1-good-slug
10-good-slugs
best-slug-ever
good-slug
slug-123
good
good-1';
my $regex = qr/^(?![0-9-]+$)(?:[a-z]{2,}-?|[0-9]-?)+(?<!-)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}