#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}(:\d{2}){2}$"
Local $sString = "" & @CRLF & _
"22:33:44" & @CRLF & _
"02:33:44" & @CRLF & _
"" & @CRLF & _
"But not as " & @CRLF & _
"" & @CRLF & _
"22:33:44 d" & @CRLF & _
"d 22:33:44" & @CRLF & _
"f 02:33:44 f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")