import re
regex = re.compile(r"^\d{2}(:\d{2}){2}$", flags=re.MULTILINE)
test_str = ("\n"
"22:33:44\n"
"02:33:44\n\n"
"But not as \n\n"
"22:33:44 d\n"
"d 22:33:44\n"
"f 02:33:44 f")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")