$re = '/^\d{2}(:\d{2}){2}$/m';
$str = '
22:33:44
02:33:44
But not as
22:33:44 d
d 22:33:44
f 02:33:44 f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);