// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{2}(:\d{2}){2}$").unwrap();
let string = "
22:33:44
02:33:44
But not as
22:33:44 d
d 22:33:44
f 02:33:44 f";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}