re = /^\d{2}(:\d{2}){2}$/m
str = '
22:33:44
02:33:44
But not as
22:33:44 d
d 22:33:44
f 02:33:44 f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end