import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^\\s*//.*(?:\\r?\\n)?";
final String string = " case kRESULT_STATUS_SHORTAGE: \n"
+ " _stprintf(outDevStr, _T(\"2000 - (Shortage issue) - %s(Shortage)\"), errorStr);\n"
+ " outError = HOP_SHORTAGE;\n"
+ " outSeverity = CCC_INFORMATION;\n"
+ " break;\n\n\n"
+ "// New Error codes(really...\n"
+ " //case kRESULT_STATUS_...\n"
+ " // _stprintf( outDevStr, _T(\"2900 - (Cover Open) -...\n"
+ " // outError = HOP_COVER_OPEN;\n"
+ " // outSeverity = CCC_INFORMATION;\n"
+ " // break;\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}