// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?m)^\s*//.*(?:\r?\n)?").unwrap();
let string = " case kRESULT_STATUS_SHORTAGE:
_stprintf(outDevStr, _T(\"2000 - (Shortage issue) - %s(Shortage)\"), errorStr);
outError = HOP_SHORTAGE;
outSeverity = CCC_INFORMATION;
break;
// New Error codes(really...
//case kRESULT_STATUS_...
// _stprintf( outDevStr, _T(\"2900 - (Cover Open) -...
// outError = HOP_COVER_OPEN;
// outSeverity = CCC_INFORMATION;
// break;
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}