# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^\s*//.*(?:\r?\n)?"
test_str = (" case kRESULT_STATUS_SHORTAGE: \n"
" _stprintf(outDevStr, _T(\"2000 - (Shortage issue) - %s(Shortage)\"), errorStr);\n"
" outError = HOP_SHORTAGE;\n"
" outSeverity = CCC_INFORMATION;\n"
" break;\n\n\n"
"// New Error codes(really...\n"
" //case kRESULT_STATUS_...\n"
" // _stprintf( outDevStr, _T(\"2900 - (Cover Open) -...\n"
" // outError = HOP_COVER_OPEN;\n"
" // outSeverity = CCC_INFORMATION;\n"
" // break;\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.