const regex = new RegExp('(?m)^\\s*//.*(?:\\r?\\n)?', 'gi')
const str = ` case kRESULT_STATUS_SHORTAGE:
_stprintf(outDevStr, _T("2000 - (Shortage issue) - %s(Shortage)"), errorStr);
outError = HOP_SHORTAGE;
outSeverity = CCC_INFORMATION;
break;
// New Error codes(really...
//case kRESULT_STATUS_...
// _stprintf( outDevStr, _T("2900 - (Cover Open) -...
// outError = HOP_COVER_OPEN;
// outSeverity = CCC_INFORMATION;
// break;
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);