use strict;
my $str = ' case kRESULT_STATUS_SHORTAGE:
_stprintf(outDevStr, _T("2000 - (Shortage issue) - %s(Shortage)"), errorStr);
outError = HOP_SHORTAGE;
outSeverity = CCC_INFORMATION;
break;
// New Error codes(really...
//case kRESULT_STATUS_...
// _stprintf( outDevStr, _T("2900 - (Cover Open) -...
// outError = HOP_COVER_OPEN;
// outSeverity = CCC_INFORMATION;
// break;
';
my $regex = qr/(?m)^\s*//.*(?:\r?\n)?/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";