re = /(?m)^\s*\/\/.*(?:\r?\n)?/i
str = ' case kRESULT_STATUS_SHORTAGE:
_stprintf(outDevStr, _T("2000 - (Shortage issue) - %s(Shortage)"), errorStr);
outError = HOP_SHORTAGE;
outSeverity = CCC_INFORMATION;
break;
// New Error codes(really...
//case kRESULT_STATUS_...
// _stprintf( outDevStr, _T("2900 - (Cover Open) -...
// outError = HOP_COVER_OPEN;
// outSeverity = CCC_INFORMATION;
// break;
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result