package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{4}|\d{6})$`)
var str = `1
12
123
12345
1234567
-1234
1.234
-1.234
00000000
1234
0000
1111
123456
098765
000000
123456
090909
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}