import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{4}|\\d{6})$";
final String string = "1\n"
+ "12\n"
+ "123\n"
+ "12345\n"
+ "1234567\n"
+ "-1234\n"
+ "1.234\n"
+ "-1.234\n"
+ "00000000\n"
+ "1234\n"
+ "0000\n"
+ "1111\n"
+ "123456\n"
+ "098765\n"
+ "000000\n"
+ "123456\n"
+ "090909\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}