const regex = /^(?:\d{4}|\d{6})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{4}|\\d{6})$', 'gm')
const str = `1
12
123
12345
1234567
-1234
1.234
-1.234
00000000
1234
0000
1111
123456
098765
000000
123456
090909
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}