#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?muJ)[\n](.*):\s(.*)-.*(👤|💂|👼|⚡️|🐶|🐺☃️|🌝🐺|🐺|💋|🕵️|🔥|👶|👁|😼|☮️|🖕|🔫|🔮|🎭|🧑🔬|🙇|🎯|🦅|🎖|🃏|🤕|🔪|👑|🧑|😈|👱🌚|👳|⚒|👷|🤯|💤|💘|🌀|📚|👨🔬)\s(.*)"
Local $sString = "بازیکن های زنده: 1 / 5" & @CRLF & _
"تست1: 💀 مرده - رمال 🦅 بازنده" & @CRLF & _
"تست2: فرار کرده - ریش سفید 📚 بازنده" & @CRLF & _
"تست3: 💀 مرده - شیمیدان 👨🔬 بازنده" & @CRLF & _
"تست4: 💀 مرده - پسر گیج 🤕 بازنده" & @CRLF & _
"تست5: 🙂 زنده - آتش زن 🔥 برنده" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"مدت زمان بازی: 00:05:31" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")