const regex = new RegExp('[\\n](.*):\\s(.*)-.*(👤|💂|👼|⚡️|🐶|🐺☃️|🌝🐺|🐺|💋|🕵️|🔥|👶|👁|😼|☮️|🖕|🔫|🔮|🎭|🧑🔬|🙇|🎯|🦅|🎖|🃏|🤕|🔪|👑|🧑|😈|👱🌚|👳|⚒|👷|🤯|💤|💘|🌀|📚|👨🔬)\\s(.*)', 'mug')
const str = `بازیکن های زنده: 1 / 5
تست1: 💀 مرده - رمال 🦅 بازنده
تست2: فرار کرده - ریش سفید 📚 بازنده
تست3: 💀 مرده - شیمیدان 👨🔬 بازنده
تست4: 💀 مرده - پسر گیج 🤕 بازنده
تست5: 🙂 زنده - آتش زن 🔥 برنده
مدت زمان بازی: 00:05:31
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}