# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\n](.*):\s(.*)-.*(👤|💂|👼|⚡️|🐶|🐺☃️|🌝🐺|🐺|💋|🕵️|🔥|👶|👁|😼|☮️|🖕|🔫|🔮|🎭|🧑🔬|🙇|🎯|🦅|🎖|🃏|🤕|🔪|👑|🧑|😈|👱🌚|👳|⚒|👷|🤯|💤|💘|🌀|📚|👨🔬)\s(.*)"
test_str = ("بازیکن های زنده: 1 / 5\n"
"تست1: 💀 مرده - رمال 🦅 بازنده\n"
"تست2: فرار کرده - ریش سفید 📚 بازنده\n"
"تست3: 💀 مرده - شیمیدان 👨🔬 بازنده\n"
"تست4: 💀 مرده - پسر گیج 🤕 بازنده\n"
"تست5: 🙂 زنده - آتش زن 🔥 برنده\n\n\n"
"مدت زمان بازی: 00:05:31\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.